Решена Не открываются URL ярлыки

fseto

Ветеран
Сообщения
1,438
Реакции
320
ты показываешь не тот скрин!
ты прав
Прикрепил то, что нужно
верно
Полностью удалил Chrome и заново установил — может косвенно поможет.. Не помогло.
Корректно работает только IE. Если сохранять страницу вот отсуда sss.jpeg ee.jpeg , то сохраняется нормально — как на скрине Chrome — gg.jpeg . Если отсюда взять cc.jpeg и перетащить на рабочий стол, то сохраняется как на скрине yandex.
В свойствах ярлыков: Chrome Тип файла: (.html), Яндекс Тип файла: (.url)
 

Вложения

  • 99999999.reg
    1.1 KB · Просмотры: 3
Последнее редактирование:

fseto

Ветеран
Сообщения
1,438
Реакции
320
Решил попрактиковаться: запустил sfc в среде восстановления 0.1 не понятно. Написало процесс начат и все ни % ничего, так и должно быть? В общем сделал по статье на OsZone.net вывод в конце работы - Все норм.
 

Кирилл

Команда форума
Администратор
Ассоциация VN
Сообщения
14,250
Реакции
6,279
Дело не в целостности файлов,а в передаче данных интерпретатору.
MS данный вопрос осветить не потрудились,я вроде как придумал как обойти это дело и воткнуть свою программу...в общем пробую.
 

Кирилл

Команда форума
Администратор
Ассоциация VN
Сообщения
14,250
Реакции
6,279
fseto, итак, что имеем.
Интерпретатор должен обрабатывать протокол,так как указано в ProgId и Hash разделов UrlAssociations.
Судя по всему с hash у тебя и проблема.

По идее спотыкаться системе больше негде,так что давай смотреть что у тебя в
Код:
HKEY_USERS\S-1-5-21-твой sid-1000\Software\Microsoft\Windows\Roaming\OpenWith\UrlAssociations
HKEY_USERS\S-1-5-21-твой sid-1000\Software\Microsoft\Windows\Shell\Associations\UrlAssociations
Жду экспорт данных разделов.

P.S. я пока экспериментировал научился без всяких заморочек запускать параллельно нужные страницы,браузеры и т.д. без подмены ассоциации файла и приписок ярлыков.
Позже надо будет повторить и снять логи - покажут ли утилиты для лечения.
 
Последнее редактирование:

Кирилл

Команда форума
Администратор
Ассоциация VN
Сообщения
14,250
Реакции
6,279
Ввиду нестандартности ситуации я лично зашел по teamwiwer к пользователю для решения проблемы.
Разобрались.
Решение - удаление некоторых фейковых разделов и пересоздание настроек ассоциации.
fseto, тему помечаю решенной?
 
Сверху Снизу